Modify

Opened 6 years ago

Last modified 6 years ago

#1151 new defect

Terminology for nodes, processes and cores is confusing

Reported by: Ian Hinder Owned by: Erik Schnetter
Priority: major Milestone:
Component: SimFactory Version:
Keywords: Cc:

Description

SimFactory's terminology for nodes, processes and cores (http://simfactory.org/info/documentation/userguide/processterminology.html) is confusing.

We should come up with a new scheme which is more consistent and intuitive. If we use new names for the options and variables, we can support both the old and new schemes at the same time, and provide a simple mapping from one to the other.

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by Barry Wardell

The main confusion is that procs could mean either processors or processes. SimFactory uses procs with the implied meaning of processors, whereas most people seem to expect it to mean processes. Would a rename of 'procs' to 'cores' eliminate all of the confusion?

comment:2 Changed 6 years ago by Ian Hinder

It sometimes also means "processes" I think. In those cases, it should be renamed to "processes".

comment:3 Changed 6 years ago by Erik Schnetter

The file "doc/processterminology.rst" explains the concepts. In this file, I use "machine", "node", and "core" for hardware concepts, and "job", "process", and "thread" for execution concepts. I could not find a good replacement for "process", which is easily confused with "processor".

Renaming variables and/or options would be a good idea.

comment:4 Changed 6 years ago by Frank Löffler

With this in mind it might be also good to have a 'noop' option for submit which would print, in nice long language, what it would do, for example (please improve):

'submitting job on 16 nodes using 32 MPI processes with 4 threads per process (2 processes with a total of 8 threads per node).'

I would totally use this before a lot of my job submissions. :)

comment:5 Changed 6 years ago by Erik Schnetter

That's a nice idea.

The output is already there, only the "-n" option is missing.

comment:6 Changed 6 years ago by bmundim

I like Frank's idea too. Also regarding the choice of "process", that could be confused for processors, but not for cores and in this case Barry's idea could be modified to add --cores instead of renaming --procs to --cores, choosing the word task or mpi-task would be a good alternative to process.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain Erik Schnetter.
Next status will be 'review'.
as The resolution will be set.
to The owner will be changed from Erik Schnetter to the specified user.
Next status will be 'confirmed'.
The owner will be changed from Erik Schnetter to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.