Modify

Opened 6 years ago

Closed 6 weeks ago

#1263 closed defect (fixed)

Multipole does not handle variable names correctly

Reported by: Ian Hinder Owned by:
Priority: major Milestone:
Component: EinsteinToolkit thorn Version:
Keywords: Multipole Cc:

Description

When you specify variables for Multipole to decompose, you have the option of giving it a "name" for the variable to be used in the output filename. This is useful if you are decomposing Psi4r, with imaginary part Psi4i, and want the file to just be named "Psi4". If you don't specify a name, it is supposed to use the original variable name. However, at the moment, this last part seems to be broken.

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by Erik Schnetter

Milestone: ET_2013_05

comment:2 Changed 5 years ago by Frank Löffler

Milestone: ET_2013_05

Not going to happen for this release.

comment:3 Changed 11 months ago by Roland Haas

Ian can you describe what actually goes wrong and ideally provide a minimal parameter file that reproduces the error? If this still applies of course (after 5 years).

comment:4 Changed 6 weeks ago by Roland Haas

Status: newreview

Pull request with a fix for this bug (not just undocumented behaviour, it was using a buffer of stale data) is here: https://bitbucket.org/einsteintoolkit/einsteinanalysis/pull-requests/7/multipole-fix-handling-case-of-missing/diff

comment:5 Changed 6 weeks ago by Ian Hinder

Resolution: fixed
Status: reviewclosed

Pull request accepted

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.