Modify

Opened 4 years ago

Last modified 5 months ago

#1658 reopened defect

ExternalLibraries/pciutils does not compile on Mac OS

Reported by: Ian Hinder Owned by:
Priority: major Milestone:
Component: Cactus Version: development version
Keywords: Cc:

Description

When I try to compile ExternalLibraries/pciutils on Mac OS, I get

lspci.c:919:29: error: expected ')'
     puts("lspci version " PCIUTILS_VERSION);
                           ^
./pciutils.h:18:26: note: expanded from macro 'PCIUTILS_VERSION'
#define PCIUTILS_VERSION PCILIB_VERSION
                        ^
lspci.c:919:11: note: to match this '('
     puts("lspci version " PCIUTILS_VERSION);

This is with the osx-mountain-lion-macports-gcc.cfg optionlist, and "gcc-mp-4.6 (MacPorts gcc46 4.6.4_3) 4.6.4".

I have to disable this thorn in my thornlist (or machine definition file) to compile the ET. This means that the ET will not compile out of the box on Mac OS.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Ian Hinder

As pointed out by Roland in #1657, there is no configure script, so gcc is used. This means the Apple gcc, which in my case is "Apple LLVM version 5.1 (clang-503.0.40) (based on LLVM 3.4svn)". When I modify the Makefile to use the MacPorts gcc, it then claims

-n Configuring libpci for your system...
 x86_64--darwin 13.3.0 x86_64 darwin
-n Looking for access methods...
 Unfortunately, your OS is not supported by the PCI Library

Indeed, the pciutils homepage (http://mj.ucw.cz/sw/pciutils/) does not list Mac OS as a supported platform. So it looks like the pciutils build system works as designed when using the MacPorts gcc.

Since pciutils does not support Mac OS, and since I would like the ET to build out of the box on Mac OS, what is the best way to make that happen?

comment:2 Changed 4 years ago by Ian Hinder

Resolution: wontfix
Status: newclosed

pciutils has been removed from the ET thornlist. Since pciutils does not support Mac OS, we can't do anything about this.

comment:3 Changed 5 months ago by Roland Haas

Resolution: wontfix
Status: closedreopened

This happened again. We should make sure that configure.sh produces a useful error message.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The ticket will remain with no owner.
Next status will be 'review'.
as The resolution will be set.
to The owner will be changed from (none) to the specified user.
The owner will be changed from (none) to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.