Modify

Opened 6 years ago

Last modified 6 years ago

#949 reopened defect

RotatingSymmetry90: abort when evaluating tensor type for Weyl scalars

Reported by: bmundim Owned by:
Priority: major Milestone:
Component: Cactus Version:
Keywords: RotatingSymmetry90 Cc:

Description

RotatingSymmetry90 is aborting when evaluating tensor type for Weyl scalars. It doesn't take into account the ManualCartesian type for example. The attached patch avoids that.

Attachments (1)

TensorTypeCheck.patch (663 bytes) - added by bmundim 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by bmundim

Attachment: TensorTypeCheck.patch added

comment:1 Changed 6 years ago by bmundim

Status: newreview

comment:2 Changed 6 years ago by bmundim

Resolution: invalid
Status: reviewclosed

On a second thought, I should actually comment out the Weyl scalars from my parameter file, since it doesn't make any sense to measure them in spherical symmetry!

comment:3 Changed 6 years ago by Roland Haas

I am not quite sure if one does not have to be a bit more careful with ManualCartesian quantities. If I define Psi = x*y2 then this would have ManualCartesian parities of (-,+,+). If I understand RotatingSymmetry90 correctly it would copy the value psi(i=10,j=1,k=0) to point (i=-1,j=10,k=0). However the Psi I defined would have (among other changes) changed sign as x (or i) changes sign. So a simple copy would not seem to be correct.

My understanding of RotatingSymmetry is limited and that of Weyl scalars very spotty at best. So don't take this objection too serious :-).

Last edited 6 years ago by Roland Haas (previous) (diff)

comment:4 Changed 6 years ago by Ian Hinder

The manual Cartesian parities specify the sign changes of the function under reflections in the planes perpendicular to the axes. These can therefore be used directly by ReflectonSymmetry. With RotatingSymmetry180, the symmetry operation is fortuitously equivalent to a reflection in the x direction composed with a reflection in the y direction, so if you know how a function transforms under reflections in the axes, you can determine how it transforms under the 180 degree rotation. RotatingSymmetry180 contains the logic to apply the parities that have been chosen. However, I don't think that a 90 degree rotation can be written as a composition of reflections, so the manual Cartesian parities are not useful here. In any case, RotatingSymmetry90 does not take account of these parities.

comment:5 Changed 6 years ago by Erik Schnetter

This patch only removes a check, it does not implement actually looking at these parities.

It does make sense to look at them -- e.g. Psi_2 contains valuable information about mass and spin also in spherical symmetry.

comment:6 Changed 6 years ago by Tanja Bode

Component: EinsteinToolkit thornCactus
Keywords: Weyl scalars removed
Resolution: invalid
Status: closedreopened

This is a duplicate of #884, which I will now close as this thread has more content. While it may not be of use to you in your specific parameter file and project, this is not strictly invalid. WeylScal4 calculates Weyl scalars besides Psi4, which may be of interest to those studying systems for which RotatingSymmetry90 is applicable. Regardless, a symmetry thorn should support all tensortypealiases available. I am reopening, but downgrading to minor as I expect this won't be of interest to many and it does abort with a helpful error. I'll get around to it when I can.

comment:7 Changed 6 years ago by bmundim

Thanks for pointing that out! I see that it has its value for the other Weyl scalars other than Psi4. Erik: thanks for pointing out the issue with the patch. I guess I rushed into it and didn't actually
implement the correct solution. I will take a deeper look later and see if I can come up with a better
patch.

Cheers!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The ticket will remain with no owner.
Next status will be 'review'.
as The resolution will be set.
to The owner will be changed from (none) to the specified user.
The owner will be changed from (none) to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.